Our Products:   CompleteFTP  edtFTPnet/Free  edtFTPnet/PRO  edtFTPj/Free  edtFTPj/PRO
0 votes
107 views
in CompleteFTP by

Why does the audit.log file contain the text document _???.xls? Where ??? these are letters in Cyrillic. Must be document_???.xls. Please answer how to fix this in CompleteFTP?

1 Answer

0 votes
by (153k points)
This looks like a bug - the audit log must be using ASCII. We'll look into getting this fixed for the next release. It has been logged in our issue tracker.
by (44.9k points)
Do they get logged correctly in the diagnostics.log file?
by (44.9k points)
You may in fact be able to solve this problem yourself.  Can you please try the following:

1. Open the following file in a text editor: C:\Program Files (x86)\Complete FTP\Server\Server\CompleteFTPService.exe.config

2. Around line 44 you should see a line starting with: <appender name="Audit"

3. Underneath this line add a new line with the following text: <encoding value="utf-8" />

4. Save the file

5. Delete (or rename) your current audit log file at C:\ProgramData\Enterprise Distributed Technologies\Complete FTP\Logs\Audit.log

6. Restart the service

7. Try uploading another file containing Cyrillic characters
by
Thanks, I decided as follows: In Windows server 2016, I changed the regional settings to Russian and not UNICODE programs in Russian either, and restart computer.

Categories

...