Our Products:   CompleteFTP  edtFTPnet/Free  edtFTPnet/PRO  edtFTPj/Free  edtFTPj/PRO
0 votes
in CompleteFTP by (159k points)
A user writes:

The Complete FTP Server service is set to Automatic startup but does not startup after reboot of the server. Manually triggering the startup works fine but we expect the server to always be running without having to start it via the console, which is what the service obviously is for.

1 Answer

0 votes
by (159k points)
Best answer

The solution was to set the service to Automatic Delayed instead of Automatic. Windows only allows 30 seconds for a service to start, and it seems this wasn't long enough for their configuration. Setting to Automatic Delayed instead of Automatic means the service is started after all automatic services are started, and presumably gives it a bit more time and resources to do so.

Another solution would be to change the default startup time to 60 seconds as described here