Our Products:   CompleteFTP  edtFTPnet/Free  edtFTPnet/PRO  edtFTPj/Free  edtFTPj/PRO
0 votes
224 views
in CompleteFTP by (120 points)

Hello Team,

We are using Version 5.3.2 (22 May, 2019) of edtFTPj/PRO in our SAP landscape to connect to the 3rd party SFTP server. However, we are getting below error.

exception caught with cause com.enterprisedt.net.j2ssh.transport.TransportProtocolException: The connection did not complete

The issue seems to be intermittent as sometimes the connection works fine and we are able to send data to the destination.

I would appreciate your help in this issue.

Thanks,

Bobby Nayak

by (5.8k points)
What protocol are you using? SFTP? Can you post more of the connection log leading up to the exception?
by (120 points)
Yes, we are using SFTP protocol. Unfortunately, we can only see "exception caught with cause com.enterprisedt.net.j2ssh.transport.TransportProtocolException: The connection did not complete" in the log.
by (5.8k points)
try setting logging so that you can debug it. See our user guide on this at:

https://enterprisedt.com/products/edtftpjssl/doc/manual/html/howtosetuplogging.html
by (120 points)
Thanks, we will try setting log and debug.

I have one question - Can expired license cause intermittent connectivity issue?
by (5.8k points)
No, not simply because the license expired. Obviously if it is a very old version then you may well get connectivity issues as we are always improving and adding algorithms, ciphers etc, and many other updates and if your version is out of date then yes connectivity problems can be experienced.
by (120 points)
Hello Stuart,

We are still getting SFTP connection error - MP: exception caught with cause com.enterprisedt.net.j2ssh.transport.TransportProtocolException: The connection did not complete for a new vendor.

We simply tried one of the enterpriseDT example for SFTP for the new vendor SFTP server credentials. As per your suggestion, we are using latest version of enterpriseDT to establish connection. However, we are getting below error in the debug mode.

DEBUG [SshClient] 22 Nov 2021 09:01:45.065 : Setting maxpacketsize=32648
DEBUG [SSHFTPClient] 22 Nov 2021 09:01:45.065 : Created SFTP client.
INFO [enterpriseDT.UseSFTPWithClientValidationPassword] 22 Nov 2021 09:01:45.081 : Connecting to server SrvFtp2.dst.dk
INFO [SCPClient] 22 Nov 2021 09:01:45.081 : SCPClient settings validated.
DEBUG [SCPClient] 22 Nov 2021 09:01:45.081 : Connecting to SrvFtp2.dst.dk:22
DEBUG [SCPClient] 22 Nov 2021 09:01:45.081 : Version: 7.2.0
DEBUG [StreamSocketFactory] 22 Nov 2021 09:01:45.096 : Connecting to SrvFtp2.dst.dk:22 via standard socket
java.net.ConnectException: Connection refused: connect
    at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method)
    at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:81)
    at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:476)
    at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:218)
    at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:200)
    at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:162)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:394)
    at java.net.Socket.connect(Socket.java:606)
    at com.enterprisedt.util.proxy.PlainSocket.createPlainSocket(PlainSocket.java:112)
    at com.enterprisedt.util.proxy.StreamSocketFactory.getConnectedSocket(StreamSocketFactory.java:73)
    at com.enterprisedt.net.j2ssh.SshClient.connect(SshClient.java:583)
    at com.enterprisedt.net.ftp.ssh.SCPClient.connectSSH(SCPClient.java:1144)
    at com.enterprisedt.net.ftp.ssh.SSHFTPClient.connect(SSHFTPClient.java:968)
    at enterpriseDT.UseSFTPWithClientValidationPassword.main(UseSFTPWithClientValidationPassword.java:55)


I would appreciate your help in this issue.


Best regards,

Bobby Nayak
by (5.8k points)
You will need to open up a support ticket at: https://enterprisedt.atlassian.net/servicedesk/customer/portal/1/group/1/create/1
if you have a current support agreement in place.
by (158k points)
Just to add to what I wrote in the support ticket - this is almost certainly a firewall issue.

Please log in or register to answer this question.

Categories

...