Our Products:   CompleteFTP  edtFTPnet/Free  edtFTPnet/PRO  edtFTPj/Free  edtFTPj/PRO
0 votes
16 views
asked in CompleteFTP by (120 points)
Hi everyone,

I need support while upgrading from an old version of CompleteFTP 9.1.3 to Version 11.0.6.

We just bought a renewal and testet the upgrade on a test VM with Windows Server 2012R2 ist worked but during upgrade on productiv server, also Windows Server 2012R2, it failed keeping the configuration:

An error occurred during the creation of the configuration file.

System.Data.SqlServerCe.SqlCeException: A foreign key value cannot be inserted because a corresponding primary key value does not exist. [ Foreign key constraint name = FK_Node_WebApp ]
   bei System.Data.SqlServerCe.SqlCeCommand.ProcessResults(Int32 hr)
   bei System.Data.SqlServerCe.SqlCeCommand.ExecuteCommandText(IntPtr& pCursor, Boolean& isBaseTableCursor)
   bei System.Data.SqlServerCe.SqlCeCommand.ExecuteCommand(CommandBehavior behavior, String method, ResultSetOptions options)
   bei System.Data.SqlServerCe.SqlCeCommand.ExecuteNonQuery()
   bei YJFjKZYG7AA2DSe8El2.avDYuZYAsl9MKTg1gel.XMMwSmOOf2(IDbConnection , String )
   bei YJFjKZYG7AA2DSe8El2.avDYuZYAsl9MKTg1gel.ATawkObP9W(IDbConnection , List`1 queries, Int32 , Int32 )
   bei YJFjKZYG7AA2DSe8El2.avDYuZYAsl9MKTg1gel.hQ9wmIJZxX()
   bei YJFjKZYG7AA2DSe8El2.avDYuZYAsl9MKTg1gel.Weaw0ZVMPr()
   bei uXlBxaiBiY93QlRivhk.kNoe8Qio8C6pS7J4MN2.W5HH060PelJ(Object , DoWorkEventArgs )
   bei System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
   bei System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

INSERT INTO WebApp VALUES ('a3b400be-9844-4025-8b17-3c9fe0499065', 'SamlSingleSignOn', '6803e4a6-ad39-4044-8130-1a08faeeefea', 'ddd24c24-b988-4ac3-a887-73218d8d9346', 1, GETDATE(), GETDATE(), NULL);

Please Help

best regards

Sascha
commented by (120 points)
A short update.
- Upgrading from 9.1.3 to 10.0.0 did not work.
- Upgrading from 9.1.3 to 10.1.1 did work!
- Upgrading from 9.1.3 to 11.0.5 did not work.
- Upgrading from 9.1.3 to 11.0.6 did not work.
- Upgrading from 10.1.1 to 11.0.5 did not work.
- Upgrading from 10.1.1 to 11.0.6 did not work.

I've tried to keep the old config file or made a new installation trying to import the old config file.

I still need help upgrading now from 10.1.1 to 11.0.6. It failed with same error as described in first post.
commented by (152k points)
Please open a ticket in our support system, here:

https://enterprisedt.atlassian.net/servicedesk/customer/portal/1

Please log in or register to answer this question.

Categories

...