Our Products:   CompleteFTP  edtFTPnet/Free  edtFTPnet/PRO  edtFTPj/Free  edtFTPj/PRO

FTP script not working

0 votes
29 views
asked Sep 13 in CompleteFTP by Andrew (140 points)
I created an ftp script on an event. I am trying to send a file to an sftp server. I see the event being processed without an error but the file does not get transferred. I can manually connect and send the file but the script doesn't do anything. Below is my script modified for public view and my log file. Is there another place were more logging exists? I have server logging level set to All.

The file to transfer is located in c:\outbound on the local complete ftp server.

set remotehost=sftpsite
set user=user
set password=password
set protocol=sftp
set localdir=C:\outbound

open

mput Certifications*.csv

close

Logging:

2017-09-13 09:29:31,922 DEBUG ProcessTrigger [Server.1] Starting sequential execution of 1 process triggers

2017-09-13 09:29:31,922 INFO ProcessTrigger [Server.1] Running process trigger UploadSkillsToKronos

2017-09-13 09:29:31,922 DEBUG ProcessTrigger [Server.1] Starting process for rule UploadSkillsToKronos (4): edtftp.exe -f "C:\ProgramData\Enterprise Distributed Technologies\Complete FTP\Temp\script1.ftp" -d

2017-09-13 09:29:31,984 DEBUG ProcessTrigger [Server.1] Finished process for rule UploadSkillsToKronos (4) after 0.058 seconds
commented Sep 13 by support2 (143,750 points)
What version of CompleteFTP are you running? In more recent versions you should see full logging output in the server log.
commented Sep 13 by Andrew (140 points)
moved Sep 13 by support2
We have version 10.1.1
commented Sep 13 by support2 (143,750 points)
I'm surprised to see no output at all. Could you please open a ticket here.

http://enterprisedt.com/support/open.php

You'll need to create a new account for this.

Please log in or register to answer this question.

...