Our Products:   CompleteFTP  edtFTPnet/Free  edtFTPnet/PRO  edtFTPj/Free  edtFTPj/PRO

No upload email being sent

0 votes
170 views
asked May 17 in CompleteFTP by rickw0708 (120 points)
I'm trying to send an email when files get uploaded but they don't generate. If I flag download and delete as well, then these emails are generated at the appropriate times but the upload email never happens.

Even if I overwrite an existing file with the upload - i get the delete email for the file but no upload email.

Any ideas why please?

1 Answer

0 votes
answered May 17 by Admin (2,230 points)

I think we'll need to see a log file to be able to troubleshoot this problem.  Can you please open a ticket at enterprisedt.com/help and attach a debug-level log file?

commented May 22 by rickw0708 (120 points)
I changed the Folder Filter to be /GUHealth/FromAU/GUHEALTH*.* and I now get the email when I transfer both the .txt and the .csv files.
Difference is - in the email I show %FILENAME% and on the .csv email it shows GUHEALTH__test.csv.filepart rather than just GUHEALTH__test.csv
commented May 22 by Admin (2,230 points)
Great.  That explains it then.  The upload doesn't match the filter until the client renames it after it's finished uploading it.  So you'll need to select the rename event as well.  That's very useful to know.  Does that explain all the behaviour you've seen?
commented May 22 by rickw0708 (120 points)
So, the Upload trigger runs whilst the upload is still in progress and the file hasn't been renamed yet like it does on successful completion? But only on CSV's?

I don't seem to have a Rename event in the Events section.
commented May 22 by Admin (2,230 points)
The event you want is called 'Move file' rather than rename.

I can't think why it should have anything to do with the extension of the file, though our tester has just reported that she's seeing different behaviour depending on the size.  Could that be the problem?

Regarding the upload event.  The upload event would've triggered when the upload was completed, but at that point the name of the file was XYZ.filepart and therefore didn't match your file filter.  I guess you could change your file filter to also match .filepart; that way you won't have to worry about the move event.  You can do this using a regular expression as follows:

regex:/GUHealth/FromAU/GUHEALTH*\.csv(\.filepart)?

The brackets around the last extension followed by the question-mark indicate that it's optional.
commented May 22 by rickw0708 (120 points)
The files size I have been testing with is only 134KB so not large at all.
Also, %TransferStatus% shows 'successful' on the Upload triggered email.

Move event works - and shows %Filename% without the .filepart.

Problem is, for a .txt file you only get the Upload trigger and no Move trigger but for .csv you get both.

May have to use the regex option instead.

Wonder why the difference in operation for .csv versus .txt
...