Our Products:   CompleteFTP  edtFTPnet/Free  edtFTPnet/PRO  edtFTPj/Free  edtFTPj/PRO
0 votes
136 views
in General by (130 points)
How to disable support for TLS 1.0 & 1.1 on CompleteFTP?

We are using pretty old version (8.5.1) but it already supports 1.2

Thanks & Regards

Mikhail

1 Answer

+1 vote
by (3.5k points)
Hi,

You should really update the software. Running old versions of software can be a security risk. We are now at CompleteFTP version 13.1.0.

You can set the minimum TLS which should be used under:

 settings (or sites) > HTTP/HTTPS > Advanced HTTP/HTTPS settings > Security Settings (also used in FTPS) > Minimum SSL Version > set the value to TLS 1.2

Please note that setting this value to TLS 1.2 will only allow clients to connect to the server who are also running TLS 1.2. If any of your clients use older legacy machine which only support TLS 1.0. or 1.1 then they will no longer be able to connect to CompleteFTP.
by (130 points)
Thanks. I changed this, restarted CompleteFTP and did an IISRESET (not sure if CompleteFTP uses IIS for its Webservices). But if I perform a TLS Check, for example with https://www.cdn77.com/tls-test it tells me TLS 1.0 is still in use and 2.0 is not available.
Any idea?
by (3.5k points)
You really need to upgrade to the latest version and retry. There have been a number of TLS 1.2 changes since your version 8.5.1
by (130 points)
Understand. Where I can get a recommended upgrade path from 8.5 to 13.1 after we renew our subscription (we have an enterprise version)?
by (3.5k points)
Hi,

Please email us at:   sales@enterprisedt.com
Please include your purchase reference number which can be found under the 'Licensing' Tab of the completeFTP manager. We will then send you a quote to  renew your support/updates agreement for your license which will then renew access to download the latest version.
by (3.5k points)
Our release history show you the many updates which have been added since version 8.5.1. You can view these at:  

https://enterprisedt.com/products/completeftp/doc/guide/index.html#/topic/history
by (3.5k points)
by (130 points)
Hi Stuart
My question is more about  a version jump from 8.5 to 13.1. Are you sure it should work?
Of course we will do a backup
by (3.5k points)
We rarely experience any issues with updating to a newer version. However we understand that some users may wish to test that an upgrade will work first, and to do this please see here: https://enterprisedt.com/questions/index.php/11604/how-can-i-test-that-a-new-release-works-for-my-server?show=11604#q11604
 You can also roll back in the event of any unforeseen issues with upgrading, please see here : https://enterprisedt.com/questions/index.php/11644/how-can-i-roll-back-to-an-earlier-version-of-completeftp?show=11644#q11644

Categories

...