Our Products:   CompleteFTP  edtFTPnet/Free  edtFTPnet/PRO  edtFTPj/Free  edtFTPj/PRO
0 votes
in .NET FTP by (130 points)
I've been using the .NET Pro version of EnterpriseDT to send files over SFTP for a while now, without any issues.  However, a short while ago, for  reasons which escape me, the public IP address of the server was changed, and since then when trying to SFTP I get the error "Server does not support diffie-hellman-group1-sha1 for keyexchange".  This seems odd to me, as it worked before, and nothing (else) has changed. Something I read suggested it might be that the key used on the server is somehow tied to the old IP, and so a new one needs to be generated.

If that's so - does anyone have any idea how I can set about doing this?

Or, can I change the keyexchange method used?

Or, any other ideas?


1 Answer

+1 vote
by (155k points)
It's likely that they are using a new server that does not have diffie-hellman-group1-sha1 enabled. You may need to upgrade to a later version that supports other key exchange algorithms  if you are using an older version.
by (130 points)
Thanks for your prompt reply.  I don't think anything has changed on their end. However, how can I check my version, and what is the property that sets the keyexchange method?
by (155k points)
You can find the DLL version in its properties via Explorer. Keyexchange is usually selected dynamically - you don't normally select it.
by (130 points)
OK, my version is - how old is that compared to the latest version?
by (130 points)
Thanks, I just tried using a trial download of the latest version, and it worked! I'll sort out an upgrade....  thanks for your help.