Our Products:   CompleteFTP  edtFTPnet/Free  edtFTPnet/PRO  edtFTPj/Free  edtFTPj/PRO
0 votes
in Java FTP by (140 points)

I am running edtftpj-pro-5.2.6 and fail to run the example Implicit FTPS connection code from EnterpriseDT to connect using FTPS to azure:

SSLFTPClient ftp = null;
ftp = new SSLFTPClient();

I don't get past the connect operation so I did not post the login process nor anything else after the connect.  I seem to run into this no matter what I try.

When I run this code I get an error:  com.enterprisedt.net.puretls.SSLHandshakeFailedException: com.enterprisedt.net.puretls.SSLPrematureCloseException: Short read when trying to connect

I have tried FileZilla and can connect with no issues:

        Response: 220 Microsoft FTP Service
        Command: AUTH TLS
        Response: 234 AUTH command ok. Expecting TLS Negotiation.
        Status: Initializing TLS...
        Status: Verifying certificate...
        Status: TLS connection established.
        Response: 331 Password required
        Command: PASS **********
        Response: 230 User logged in.
        Command: OPTS UTF8 ON
        Response: 200 OPTS UTF8 command successful - UTF8 encoding now ON.
        Command: PBSZ 0
        Response: 200 PBSZ command successful.
        Command: PROT P
        Response: 200 PROT command successful.
        Status: Logged in
        Status: Retrieving directory listing...
        Command: PWD
        Response: 257 "/" is current directory.

        What am I missing?  Bear with me if I missed something in the example.  I don't often turn to Support forums...

        1 Answer

        0 votes
        by (47.9k points)
        Judging by the FileZilla log, the server is not an implicit FTPS server, so please remove the call to setImplicitFTPS.