Our Products:   CompleteFTP  edtFTPnet/Free  edtFTPnet/PRO  edtFTPj/Free  edtFTPj/PRO

SecureFTPConnection works on devlopment PC, fails on target PC

0 votes
93 views
asked Nov 17, 2016 in .NET FTP by mskille (190 points)
I construct a SecureFTPConnection instance setting these properties:
            ServerAddress = address;
            UserName = user;
            Password = pwd;
            Timeout = timeout;
            ConnectMode = FTPConnectMode.PASV;
            DeleteOnFailure = false;
            TransferNotifyInterval = 512;
            CloseStreamsAfterTransfer = false;
            DefaultFolder = path;
            // Copied from an example on the edtFTPnet forum:
            LicenseOwner = "<my user name>";
            LicenseKey = "<my license key>";

When I run the executable using this connection on my development PC (where I have installed the edtFTPnet/PRO library), all works fine towards a sftp server with the given address and user/password.

When I run the very same executable addressing the very same server from another PC (my laptop), an exception is thrown claiming the license is invalid.

What is needed to have this working on any PC towards the sftp server?

My development PC is running Windows 7, my laptop runs Window 10.

My edtFTPnet library version is 8.6.2.20.

Any help is highly appreciated.
commented Nov 17, 2016 by support2 (144,210 points)
You need to explicitly set the LicenseOwner and LicenseKey properties with your license details.
commented Nov 17, 2016 by mskille (190 points)
Where? I do set the LicenseOwner and LicenseKey according to our license in when constructing the SecureFtpConnection in the program, and as mentioned, it works on my development PC but not on the Laptop.
Should the software installer do any special tricks, or should I set the license information in the application configuration file as well? It is not encrypted, so the license information will be available to anyone...
commented Nov 17, 2016 by support2 (144,210 points)
Oops, I missed where you were setting them explicitly - that looks correct. I guess it is possible that the license is invalid and it is getting the values from the registry on the dev machine. You can open a support ticket and give us the license details to check.
http://enterprisedt.com/support/open.php

Please log in or register to answer this question.

...