Our Products:   CompleteFTP  edtFTPnet/Free  edtFTPnet/PRO  edtFTPj/Free  edtFTPj/PRO

edtFtpPro version 9.1.1.2.0 fails to build setup project

0 votes
42 views
asked Apr 25 in .NET FTP by newm2156 (1,390 points)
When upgrading to new Windows server required us to update to latest version of edtFtpPro 9.1.1.2.0. All worked until trying to build the setup deployment package or refresh the dependencies in Visual Studio 2010 or 2015. In all cases the build failed in the setup project with version 9.1.1.2.0. Creating a new project failed to allow the package to be built and throws an error as before.

Reverting to version 8.4.0.20 allowed the setup project to build in both a .net 4 and .net 3.5 environments with no change other than switching the dlls out.

The failure output is:

ERROR: Unable to update the dependencies of the project.  The dependencies for the object 'edtFTPnetPRO.dll' cannot be determined.

I have tried some suggestions for this from Stackoverflow, etc to no avail.

 

Thoughts?
commented Apr 25 by support2 (143,330 points)
Please open a support ticket here:

http://enterprisedt.com/support/index.php
commented Jun 1 by stumac68 (150 points)
Same problem for a number of developers in the company I'm working with.
Using VS2010, updated one of the projects within the solution from v7.3.1.20 to v9.1.1.20. There is a setup project and this throws the exact same error.
Tried setting up a new VS2013 solution and exact same problem. Revert back to v7.3.1.20 and no problems. It just seems to be this new version.
commented Jun 1 by support2 (143,330 points)
Apparently the latest version of  the obfuscator we are using is causing this issue. Please email us for a link to a build we've done with the previous version. We will soon do a new release that uses the old obfuscator.
commented Jun 1 by stumac68 (150 points)
Thanks Support. Which email address do I need to use?
commented Jun 1 by support2 (143,330 points)
support at enterprisedt dot com

Please log in or register to answer this question.

...