Discuss , our SFTP/FTP/FTPS/SCP server for Windows. Secure, fast and customizable!
no avatar
User

jbottoms

Posts

6

Joined

Tue May 05, 2015 11:35 pm

Custom FileSystemAdapter no longer working as expected

by jbottoms » Thu Jun 25, 2015 6:50 am

Hi,
I recently upgraded to 8.3.1 from 8.2.0.3 and my custom FileSystemAdapter no longer works as expected. My custom adapter is a wrapper that allows us to stream uploaded files directly to our database. It is fairly simple, in that it only allows uploading files, no directory browsing or viewing/downloading files. Using 7.3 I implemented only the following methods:
FileExists
GetWriteStream
OnWriteStreamClosed
GetFileInfos

When I upgraded to 8.2.0.3 I had to implement SetModifiedTime and DirectoryExists.

Now however, with 8.3.1, I'm getting an "unknown path:" error, which appears to happening after the file is successfully streamed to the file system adapter. Here is the log

2015-06-24 16:13:34,164 INFO SFTPSubsystemServer [Session.1:Default Site:testuser:127.0.0.1] Opened /Dataload/Borrower/Copy of LoanBalances.xls for writing
2015-06-24 16:13:34,172 INFO FileDetails [Session.1:Default Site:testuser:127.0.0.1] Closed file /Dataload/Borrower/Copy of LoanBalances.xls
2015-06-24 16:13:34,173 WARN SFTPSubsystemServer [Session.1:Default Site:testuser:127.0.0.1] unknown path: /Dataload/Borrower/Copy of LoanBalances.xls
2015-06-24 16:13:34,173 WARN SFTPSubsystemServer [Session.1:Default Site:testuser:127.0.0.1] Sending SSH_FXP_STATUS [requestid=33289,code=2,msg=unknown path: /Dataload/Borrower/Copy of LoanBalances.xls]

It appears that I can work around this issue by changing my ftp client (winSCP) to not "Preserve timestamp", however, this is obviously not tenable in our Production environment.

My question is there something else that I have to implement? Note that my current implementation of SetModifiedTime doesn't actually do anything.

Thanks

Jon
no avatar
User

support2

Posts

3987

Joined

Tue May 18, 2004 8:30 am

Re: Custom FileSystemAdapter no longer working as expected

by support2 » Thu Jun 25, 2015 8:00 am

Hi Jon

We've opened a ticket for you in our help-desk system. You should have receive a response by e-mail.

- Hans (EnterpriseDT)

Who is online

Users browsing this forum: No registered users and 0 guests

Powered by phpBB ® | phpBB3 Style by KomiDesign
cron